WordPress Error Fatal error: Cannot redeclare pclziputilpathreduction()

WordPress Error | Fatal error: Cannot redeclare pclziputilpathreduction() | Solution

I guess you stumbled this page after getting this error on “Fatal error: Cannot redeclare pclziputilpathreduction()”? It looks just like this.

Fatal error: Cannot redeclare pclziputilpathreduction()

Fatal error: Cannot redeclare pclziputilpathreduction()

How I managed to get the problem “Fatal error: Cannot redeclare pclziputilpathreduction()”

After reading on Macuha’s post on the Global Translator effect, I tried  to do it too (copycat!). Aside from that, I also want to know about wordpress’ auto plug-in install (my next post) so I did some checking and when I was about to install it, I got this error.

Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/silken/public_html/blog/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/xxxxxx/wp-admin/includes/class-pclzip.php on line 5498

Solution to this error.

After doing a bit of Googling, the solution to this error is to Deactivate the wordpress automatic upgrade plug-in and that’s it. No more problems!

I hope it works for you too. ^_^

10 thoughts on “WordPress Error Fatal error: Cannot redeclare pclziputilpathreduction()

  1. THANK YOU!!!!!!!!!!!!!!!! I was starting to tear out my hair! Worked a treat … xx

    Sandys last blog post..Interactive Lenormand Oracle e-book

  2. You rock! This worked great… Thanks for taking the time to post this. Could it be that I was running an older version of the plugin? Other sites I run don’t have this problem.

    billys last blog post..Carl Sagan on UFO’s

  3. Hmm… I read blogs on a similar topic, but i never visited your blog. I added it to favorites and i’ll be your

    constant reader.

  4. damn! so simple solution…
    i forgot that i installed that plugins before.
    thanks man!!

  5. Bless you for your helping hand.

  6. I tried to turn off automatic installation, but then realized that I do not have that plug in installed? I still have this error and have no idea why.

    Thanks for your help,

    H

  7. I have the same proble, it occures during the activation of the plugin.

    Also I notice that this problem only occures when i include a file on the top of the main plugin file. I have to include the file so that I can also instantiate my class so that I can use is globally to all my finctions.

    how to do this properly?

    I need help ASAP

Leave a Reply