List of OpenKore Error Codes

Unknown error code 10060? Unknown error code 10065? What the hell do they mean?

Here are the meanings of the different error codes that you might encounter in Openkore.


Error Code List

10013 => ‘Permission denied.’,
10048 => ‘Address already in use.’,
10049 => ‘Cannot assign requested address.’,
10047 => ‘Address family not supported by protocol family.’,
10037 => ‘Operation already in progress.’,
10053 => ‘Software caused connection abort.’,
10061 => ‘Connection refused.’,
10054 => ‘Connection reset by peer.’,
10039 => ‘Destination address required.’,
10014 => ‘Bad address.’,
10064 => ‘Host is down.’,
10065 => ‘No route to host.’,
10036 => ‘Operation now in progress.’,
10004 => ‘Interrupted function call.’,
10022 => ‘Invalid argument.’,
10056 => ‘Socket is already connected.’,
10024 => ‘Too many open files.’,
10040 => ‘Message too long.’,
10050 => ‘Network is down.’,
10052 => ‘Network dropped connection on reset.’,
10051 => ‘Network is unreachable.’,
10055 => ‘No buffer space available.’,
10042 => ‘Bad protocol option.’,
10057 => ‘Socket is not connected.’,
10038 => ‘Socket operation on nonsocket.’,
10045 => ‘Operation not supported.’,
10046 => ‘Protocol family not supported.’,
10067 => ‘Too many processes.’,
10043 => ‘Protocol not supported.’,
10041 => ‘Protocol wrong type for socket.’,
10058 => ‘Cannot send after socket shutdown.’,
10044 => ‘Socket type not supported.’,
10060 => ‘Connection timed out.’,
10035 => ‘Resource temporarily unavailable.’,
11001 => ‘Host not found.’,
10093 => ‘Successful WSAStartup not yet performed.’,
11004 => ‘Valid name, no data record of requested type.’,
11003 => ‘This is a nonrecoverable error.’,
10091 => ‘Network subsystem is unavailable.’,
11002 => ‘Non-authoritative host not found.’,
10092 => ‘Winsock.dll version out of range.’,
10094 => ‘Graceful shutdown in progress.’

Source: http://forums.openkore.com/viewtopic.php?t=31099&start=90

27 thoughts on “List of OpenKore Error Codes

  1. psychosedated says:

    good job /no1
    keep up the good work…
    asteg talaga tung si Sir Allen hehehe…

    Allen Reply: Thanks! ^_^ You can suggest something that I could write or if you have questions, just fire away. My next guide would be general configurations.

  2. psychosedated says:

    uhm… sir Allen I’m having a bit of a problem with my bot…
    im currently botting at lhz_fild01 (metaling map), everytime i go back to town to re-stock on wakes and dump my loots at the kafra storage, i can’t seem to go back lhz_fild01 it just moves around town. here’s my config btw:

    lockMap lhz_fild01
    lockMap_x
    lockMap_y
    lockMap_randX
    lockMap_randY

    route_escape_unknownMap 1
    route_escape_reachedNoPortal 1
    route_escape_randomWalk 1
    route_escape_shout
    route_randomWalk 1
    route_randomWalk_inTown 0
    route_randomWalk_maxRouteTime 75
    route_maxWarpFee
    route_maxNpcTries 5
    route_teleport 0
    route_teleport_minDistance 150
    route_teleport_maxTries 8
    route_teleport_notInMaps
    route_step 15

    anything i should change?
    TIA for the reply.
    keep it up your guides are really helpful for noob botters such as myself hehehe. /thx šŸ™‚

    Allen Reply: Hello,
    the bot should not move around town since route_randomWalk_inTown is 0.

    btw, in what town are you restocking? Thanks. ^_^
    As far as I know, your config looks ok.

  3. psychosedated says:

    lighthalzen sir. My bot can’t seem to enter the portal šŸ™

    Allen Reply: From what town are you coming from? and you are going to lhz_fild01 right?

    (I apologize for this since Iā€™m not that familiar with the new maps. ^_^

  4. psychosedated says:

    whoops mah bad, its coming from Lighthalzen town šŸ™‚

    • Hi there, sorry for the late reply. To enable the bot to use portals, usually you have to edit the file portals.txt that can be found inside the tables folder. I just checked the file and there seems to be no entry for Lighthalzen.

      This is what you can do.

      [1] lockmap in lighthalzen town and set route_randomWalk_inTown to 1. It will go around the town storing npcs and portals that it finds. After a while of going around, close openkore and open it again. It will ask you to recompile a new PortalsLos.txt file. We can then add new entries to the portals. txt file based on this data (but this sounds comlicated, so let’s try # option 2 first)

      OR

      [2]
      add this into your portals.txt file and type “reload portals.txt” from openkore console or rereun openkore.

      lighthalzen 267 200 lighthalzen 303 229 0 c n
      lighthalzen 294 223 lighthalzen 260 199 0 c n
      lighthalzen 313 301 lhz_cube 231 12 0 c c r0 n
      lhz_cube 231 12 lighthalzen 310 302
      lhz_cube 231 96 lhz_dun02 220 6
      lhz_dun02 224 6 lhz_cube 231 90
      lhz_dun02 149 149 lhz_dun03 140 133
      lhz_dun03 139 137 lhz_dun02 149 142
      lhz_dun02 283 153 lhz_dun01 281 154
      lhz_dun02 17 153 lhz_dun01 18 150lhz_dun02 146 19 lhz_dun02 17 156
      lhz_dun02 17 156 lhz_dun02 159 33
      lhz_dun02 146 19 lhz_dun01 144 9
      lhz_dun01 149 9 lhz_dun02 153 19
      lhz_dun01 18 145 lhz_dun02 17 150
      lhz_dun02 17 156 lhz_dun01 18 150
      lhz_dun02 282 161 lhz_dun01 281 154
      lhz_dun01 281 150 lhz_dun02 282 153

      Please tell me if it works since this the first time I’ve encountered this. ^_^

  5. psychosedated says:

    sir is this a bug or something? my bot can’t seem to calculate a route to lhz_fild01 rather he calculates a random route inside lighthalzen town. Have you experienced this before? same thing happened to me at geffen šŸ™

    Allen Reply: Is your lockmap currently in town? Perhaps you have two entries for Lockmap? šŸ˜€

    • psychosedated says:

      no im sure its in lhz_fild01 šŸ™ dis sux big time…

      Allen reply:Can you send me a copy of your config to my email? Just erase your account details before sending. Thanks.

      If worse comes to worse, you can just reconfigure your bot from the start. I’ve done this a few times when I was just starting. šŸ™‚

  6. Hi psychosedated,

    Something’s wrong with the blog. Your last comments disappeared, can you write them again? Thanks.

  7. psychosedated says:

    uhm sir if i get the error code 10061 (connection refused) how do i fix this?

    Allen reply: Check levelup’s website to see the status of the games. Other than that, it’s just similar to Error code 10060 where you will just have to wait. šŸ™‚

  8. i can open it but there are many errors..
    in the error report it says

    OpenKore version 2.0.5.1
    Network state = 2
    Network handler = Network::DirectConnection
    SVN revision: unknown
    No loaded plugins.

    Error message:
    Assertion (‘HASH(0x33adcb0)’ must be of class ‘Actor::You’) failed!
    at C:/Documents and Settings/user/Desktop/openkore-2.0.5.1/src/deps/Carp/Assert.pm line 271
    Carp::Assert::assert(”, ‘\’HASH(0x33adcb0)\’ must be of class \’Actor::You\”) called at src/Utils/Assert.pm line 31
    Utils::Assert::assertClass(‘HASH(0x33adcb0)’, ‘Actor::You’) called at src/Misc.pm line 223
    Misc::checkValidity(‘parseInput’) called at src/functions.pl line 64
    main::mainLoop() called at src/Interface.pm line 75
    Interface::mainLoop(‘Interface::Console::Win32=HASH(0x2b084a4)’) called at openkore.pl line 96
    main::__start() called at start.pl line 125

    Stack trace:
    Assertion (‘HASH(0x33adcb0)’ must be of class ‘Actor::You’) failed!
    at C:/Documents and Settings/user/Desktop/openkore-2.0.5.1/src/deps/Carp/Assert.pm line 271
    Carp::Assert::assert(”, ‘\’HASH(0x33adcb0)\’ must be of class \’Actor::You\”) called at src/Utils/Assert.pm line 31
    Utils::Assert::assertClass(‘HASH(0x33adcb0)’, ‘Actor::You’) called at src/Misc.pm line 223
    Misc::checkValidity(‘parseInput’) called at src/functions.pl line 64
    main::mainLoop() called at src/Interface.pm line 75
    Interface::mainLoop(‘Interface::Console::Win32=HASH(0x2b084a4)’) called at openkore.pl line 96
    main::__start() called at start.pl line 125
    at C:/Documents and Settings/user/Desktop/openkore-2.0.5.1/src/deps/Carp/Assert.pm line 271
    Carp::Assert::assert(”, ‘\’HASH(0x33adcb0)\’ must be of class \’Actor::You\”) called at src/Utils/Assert.pm line 31
    Utils::Assert::assertClass(‘HASH(0x33adcb0)’, ‘Actor::You’) called at src/Misc.pm line 223
    Misc::checkValidity(‘parseInput’) called at src/functions.pl line 64
    main::mainLoop() called at src/Interface.pm line 75
    Interface::mainLoop(‘Interface::Console::Win32=HASH(0x2b084a4)’) called at openkore.pl line 96
    main::__start() called at start.pl line 125

    HOW can i fix it??

    Allen reply: Did you edit the source codes and recompiled it? If not, download a fresh copy from openkore website.

  9. sir allen,i have a problem i have this error code 10061 which means connection refused from above..
    what should i do about this??..

  10. rayvonVarron – Please read above comments. šŸ™‚

  11. hellow allen…. can u give me the portals of ra_fild05 because everytime i open my bot and the lockmap was ra_fild05 it always saying that cannot calculate a route i think it needs the portals of rachel fields…
    thats all thx!

  12. @neilbert – Have you downloaded the “fields.txt” pack and pasted it in the Tables folders of your OpenKore folder? If you have done so and still the bot searches for the portals, you can upload them manually. Simply run your bot in Rachel and every portal it sees will automatically be registered. ^_^

  13. uhm…sir you know about the error codes right….what should I do if I get 10060 because it doesn’t connect often and also why does it say disconnected on map server (i think that’s it..kind of like that…) should I do something so that it doesn’t disconnect?

    I open poseidon before I use my bot…so what should I do…I really can’t gain a lot of exp because it keeps on disconnecting…here’s my config:

    can you also give me the latest server packets available for my server? Thanks soooo much in advance!!

  14. Uhm, i have the 10060 error code, it kept reconnecting but it don’t seem to work. What should I do?

  15. ie i have a problem with my bot in aero, my bot is connecting and connecting but it didnt connect in the game…. i hope u can help me…
    heres a screenshot:

  16. solve na ba ung problem sa lighthalzen?

  17. pano po ayusin yung error 10013?

  18. can anyone help me how to fix error 10051? thnx

  19. sir what does “unable to calculate a route” means?
    and why my assassin does not attack any monsters?
    need help plz….

  20. hey anyone can give me a config for my swordie?my openkore always disconnect and im tired of relogging it every monster i kill…so plssss help me wid dis prob…add me at yahoo kev2_14@yahoo.com plssss help me guys anyone der!!!!!!!!!!!!:)thanks

  21. I have a problem with my openkore. When I start it, I always get stuck at the character server and then the connection times out and I get either a 10060 or 10061 error. I have the newest version, I believe. Any help?